FileSieve 4

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report (major)
  • Category Plugin
  • Assigned To
    Joseph Cox
  • Operating System All
  • Severity High
  • Priority High
  • Reported Version 4.06
  • Due in Version 4.07
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: FileSieve 4
Opened by Joseph Cox - 10 December 2016
Last edited by Joseph Cox - 10 December 2016

FS#155 - Method: Tag; path separator tags are being stripped

See forum post.

This...

\%GENRE_FIRST%\%ALBUM_ARTIST_FIRST%\%ALBUM_TITLE%\

becomes this...

Y:\Music\ContemporaryTedCrillyA Song for Europe\FileName.mp3

Initial thoughts are that FileSieve is stripping slashes due to - possibly - a call to MakeFilesystemLegal().

Closed by  Joseph Cox
10 December 2016 02:24 PM
Reason for closing:  Fixed
Additional comments about closing:  

Thanks for reporting, Doug!

Admin
Joseph Cox commented on 10 December 2016 02:03 PM

Bug confirmed.

Admin
Joseph Cox commented on 10 December 2016 02:10 PM

Investigate the EXIF plugin to see if it is also affected by this bug as they're very similar in implementation.

Admin
Joseph Cox commented on 10 December 2016 02:17 PM

The bug seems to be within the actual Tag plugin itself so a rebuild of FileSieve isn't required.

Tag.GetValue() appears to be the culprit.

Admin
Joseph Cox commented on 10 December 2016 02:23 PM

Fixed.

Problem was indeed due to a MakeFilesystemLegal() call when the Tag.GetValue() function returned.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing