View Issue Details

IDProjectCategoryView StatusLast Update
0000243Pad Device Status[All Projects] Backend / Corepublic2018-11-20 12:05
ReporterAppFrameworkAssigned ToBootBlock 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.06 
Target Version1.07Fixed in Version1.07 
Summary0000243: Exception: opacity must be in the range of 0 to 1.Parameter name: opacity
Description

This report has been created by the AppFramework framework on which the XBox Device Status application has been built.
This report has been submitted with the user's express permission.


APPLICATION INFORMATION

  • Version: 1.6
  • Uptime: 1 seconds
  • Command Line: C:\Program Files (x86)\XBox Device Status\XBox Device Status.exe
  • Open Forms
    • XBDS.Forms.Main
  • Loaded Assemblies
    • mscorlib, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • XBox Device Status, Version=1.6.0.0
    • BiQubic.Suite.Core, Version=1.25.0.0
    • System.Drawing, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • BiQubic.Suite.FileSystem, Version=1.15.0.0
    • BiQubic.Suite.Metro, Version=1.22.0.0
    • System.Windows.Forms, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • BiQubic.Suite.Controls, Version=1.10.0.0
    • Microsoft.VisualBasic, Version=10.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Core, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Web, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Management, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Configuration, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Xml, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Newtonsoft.Json, Version=11.0.0.0, PublicKeyToken=30ad4fe6b2a6aeed
    • System.Numerics, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Runtime.Serialization, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Data, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Speech, Version=4.0.0.0, PublicKeyToken=31bf3856ad364e35
    • Accessibility, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • MantisSharp, Version=1.0.0.0, PublicKeyToken=05b8fbd1b10b2d7e

EXCEPTION

MESSAGE
  • opacity must be in the range of 0 to 1.
    Parameter name: opacity
SOURCE
  • BiQubic.Suite.Metro
TARGET SITE
  • Name: SetOpacitySaturationBrightness
  • MemberType: Method
  • Module: BiQubic.Suite.Metro.dll
STACKTRACE
  • at BiQubic.Suite.Metro.Utility.Image.SetOpacitySaturationBrightness(Image image, Single opacity, Single saturation, Single brightness)
  • at BiQubic.Suite.Metro.Forms.Controls.MetroPictureBox.ProcessImages()
  • at BiQubic.Suite.Metro.Forms.Controls.MetroPictureBox.set_ImageOpacity(Single value)
  • at XBDS.Forms.Main.tmrHighlightMenu_Tick(Object sender, EventArgs e)
  • at System.Windows.Forms.Timer.OnTick(EventArgs e)
  • at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
  • at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

APPFRAMEWORK INFORMATION

  • Version: 1.25
  • HasStartupErrors: Yes
  • LaunchCount: 4
  • TotalDuration: 00:04:25.2203186

SYSTEM INFORMATION

  • ID: 8C6C961CA815859FA4AEB3398A290CBFAD442188
  • Operating System: Microsoft Windows 10 Pro (6.2.9200.0; Win32NT; x64)
  • Physical Memory: 21,479 MB free of 32,630 MB
  • Virtual Memory: 3,735 MB free of 4,095 MB
  • Working Set: 72 MB
  • CPUs: 8

ENVIRONMENT

  • Displays: 1920x1080x32 (1920x988)*
  • .NET Frameworks: 2.0, 3.0, 3.5, 4 Client, 4 Full
  • .NET Version: 4.0.30319.42000
  • Culture: en-US (English (United States))
  • Input Language: en-US (US)
  • VisualStyles: Enabled

USER COMMENTS

The error is thrown upon launching XBDS.

APPFRAMEWORK LOG

  • [2018-11-19 at 5:02:41 PM] Startup Information XBox Device Status v1.6.0.0
  • [2018-11-19 at 5:02:41 PM] Startup Information OS: Microsoft Windows 10 Pro 6.2.9200.0 (Win32NT; x64). CPUs: 8.
  • [2018-11-19 at 5:02:41 PM] Startup Information Memory: 21.01GB of 31.87GB free.
  • [2018-11-19 at 5:02:42 PM] Startup Information UI Culture: English (United States)
  • [2018-11-19 at 5:02:42 PM] Startup Debug Exception handler has been initialised to use MantisBT.
  • [2018-11-19 at 5:02:42 PM] Plugins Verbose Plugins directory exists but is empty. Plugin support is set to ScanInstantiate.
  • [2018-11-19 at 5:02:42 PM] Startup Information Using version 1.4 of XInput.
  • [2018-11-19 at 5:02:43 PM] AppFramework Fatal An exception has been caught: opacity must be in the range of 0 to 1.
    Parameter name: opacity
TagsException

Relationships

has duplicate 0000245 resolvedBootBlock Exception: opacity must be in the range of 0 to 1.Parameter name: opacity 
has duplicate 0000244 resolvedBootBlock Exception: opacity must be in the range of 0 to 1.Nome do parĂ¢metro: opacity 

Activities

BootBlock

2018-11-20 11:31

administrator   ~0000010

Yikes; the Opacity parameter can only accept a range of zero to one, except that a value of -1.56462193E-07 is being passed in!

BootBlock

2018-11-20 11:36

administrator   ~0000011

This seems to be a floating point rounding error. Impossible to stop that at a low level, but I can add a check that'll prevent the insanity from bubbling up into the application.

BootBlock

2018-11-20 11:39

administrator   ~0000012

Fixed.

Thanks to everyone that reported the issue!

Issue History

Date Modified Username Field Change
2018-11-19 22:03 AppFramework New Issue
2018-11-19 22:03 AppFramework Assigned To => BootBlock
2018-11-20 11:31 BootBlock Note Added: 0000010
2018-11-20 11:36 BootBlock Note Added: 0000011
2018-11-20 11:39 BootBlock Note Added: 0000012
2018-11-20 11:42 BootBlock Relationship added has duplicate 0000245
2018-11-20 11:43 BootBlock Relationship added has duplicate 0000244
2018-11-20 11:44 BootBlock Priority normal => immediate
2018-11-20 11:44 BootBlock Severity minor => block
2018-11-20 11:44 BootBlock Reproducibility have not tried => always
2018-11-20 11:44 BootBlock Status new => resolved
2018-11-20 11:44 BootBlock Resolution open => fixed
2018-11-20 11:44 BootBlock Product Version => 1.06
2018-11-20 11:44 BootBlock Fixed in Version => 1.07
2018-11-20 11:44 BootBlock Target Version => 1.07
2018-11-20 11:44 BootBlock Summary Exception: opacity must be in the range of 0 to 1.
Parameter name: opacity => Exception: opacity must be in the range of 0 to 1.Parameter name: opacity
2018-11-20 12:05 BootBlock Tag Attached: Exception