View Issue Details

IDProjectCategoryView StatusLast Update
0000321Comica 2[All Projects] Backend / Corepublic2019-03-05 08:30
ReporterBootBlockAssigned ToBootBlock 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.00 
Target Version2.00Fixed in Version 
Summary0000321: Saving with DatabaseEditor causes a load problem
Description

Implementing the DatabaseEditor and saving with it seems to have caused an issue the next time the modified database is loaded from disk.

The error happens when ComicUrl is set and it's trying to access the database's .Parent property (to check the PublisherUrl). This is because ComicUrl is firing before Comics.AssociateDefinitionsWithParent() has been called. No idea why this worked previously and it isn't now; surely this ComicUrl firing would always happen as it's never null.

Steps To Reproduce
  1. Use the Database Editor, modify the database, and save it.
  2. Exit Comica.
  3. Run Comica again.
  4. Observe the exception in Definition.ComicUrl.
TagsNo tags attached.

Relationships

related to 0000320 assignedBootBlock Add a Database Editor pane 

Activities

BootBlock

2019-02-27 17:03

administrator   ~0000057

Setting the ComicUrl property now checks to see if Parent is null; would've preferred to have found the root cause, but this now works as it initially was expected to.

Issue History

Date Modified Username Field Change
2019-02-27 09:45 BootBlock New Issue
2019-02-27 09:45 BootBlock Assigned To => BootBlock
2019-02-27 09:46 BootBlock Relationship added related to 0000320
2019-02-27 17:03 BootBlock Note Added: 0000057
2019-02-27 17:03 BootBlock Status new => closed
2019-02-27 17:03 BootBlock Resolution open => fixed
2019-03-05 08:30 BootBlock Status closed => resolved