View Issue Details

IDProjectCategoryView StatusLast Update
0000372Comica 2[All Projects] Backend / Corepublic2019-05-13 20:45
ReporterBootBlockAssigned ToBootBlock 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.23 
Target Version2.00Fixed in Version 
Summary0000372: Add Comic Name to a comic's Metastore data
Description

When a comic strip is archived to disk, a .metastore file is created that contains meta-information on that downloaded strip (eg. download date). Alongside the Guid field, add a Name (or something to that effect) field that has the name of the comic that owns that metastore.

Comica will treat the Name field as write-only as it'll just be for the user's benefit should they want to go poking around the data files.

Update the field when a new strip is added to .metastore just in case it changed since the last update.

TagsNo tags attached.

Relationships

child of 0000264 closedBootBlock Replace the "Meta-store" with individual stores 

Activities

BootBlock

2019-05-13 20:45

administrator   ~0000092

The .Name field is updated when the store's owning parent .Definition property is re-associated upon database load.

Issue History

Date Modified Username Field Change
2019-05-13 20:32 BootBlock New Issue
2019-05-13 20:32 BootBlock Assigned To => BootBlock
2019-05-13 20:33 BootBlock Relationship added child of 0000264
2019-05-13 20:34 BootBlock Status new => assigned
2019-05-13 20:45 BootBlock Status assigned => closed
2019-05-13 20:45 BootBlock Resolution open => fixed
2019-05-13 20:45 BootBlock Note Added: 0000092