View Issue Details

IDProjectCategoryView StatusLast Update
0000380FileSieve[All Projects] Backend / Corepublic2019-05-18 14:15
ReporterBootBlockAssigned ToBootBlock 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.41 
Target Version4.42Fixed in Version 
Summary0000380: Display message if the Registered plugin crashes on initialisation
Description

While FileSieve gives the user information when the Registered plugin is outdated, it doesn't actually say anything specific should the Registered plugin exception during interrogation by the plugin system.

The reason this issue was encountered was due to changing the IPlugin interface (added a ProfileFinishing(profile) method) and Registered crashing, as expected, but what wasn't expected was that the user isn't notified of this (except for a generic plugin load error within the Log) and so their licensed copy of FileSieve became the Free edition.

Now, a message is displayed and they can optionally visit their FileSieve account to update the plugin.

Steps To Reproduce

Run FileSieve 4.42 or above with a Registered plugin that has a version lower than 4.42.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-05-18 14:11 BootBlock New Issue
2019-05-18 14:11 BootBlock Assigned To => BootBlock
2019-05-18 14:15 BootBlock Status new => resolved
2019-05-18 14:15 BootBlock Resolution open => fixed
2019-05-18 14:15 BootBlock Summary Display message if Registered plugin crashes crashes on Init => Display message if the Registered plugin crashes on initialisation