View Issue Details

IDProjectCategoryView StatusLast Update
0000408BiQubic FrameworkAPIpublic2020-01-21 16:24
ReporterBootBlock Assigned ToBootBlock  
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
Summary0000408: Can't submit exceptions
Description

This has happened before and I thought I fixed it, but it's happening now either way.

Sending an exception report results in the tracker giving a 403 Forbidden error when trying to list projects. The textual description is:

User does not have access right to report issues

If I remember, the submitter is using the wrong user? Maybe Anonymous?

TagsBiQubic.Framework

Activities

BootBlock

2020-01-02 09:56

administrator   ~0000137

I've added a specific catch for the user rights issue that notifies the user about the problem, just in case it happens again in the future on a user's machine.

Still haven't (re)discovered the issue, though...

BootBlock

2020-01-02 11:01

administrator   ~0000138

Last edited: 2020-01-02 11:03

View 1 revisions

Alright, fixed. Turns out updating MantisBT broke a change I had to make to get authorisation working as it seems the Authorization header isn't be preserved when using the REST API. For future reference:

1) Open /api/rest/.htaccess in a text editor.
2) Add the following line to the top: SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0
3) Save it. Should now accept submissions.

At the time of writing, the .htaccess for MantisBT 2.23.0 should entirely consist of the following (note the addition of the first line):

SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0

# Based on Slim Framework recommendation @ http://docs.slimframework.com/routing/rewrite/
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [QSA,L]

Issue History

Date Modified Username Field Change
2020-01-02 09:45 BootBlock New Issue
2020-01-02 09:45 BootBlock Assigned To => BootBlock
2020-01-02 09:45 BootBlock Tag Attached: BiQubic.Framework
2020-01-02 09:56 BootBlock Note Added: 0000137
2020-01-02 11:01 BootBlock Note Added: 0000138
2020-01-02 11:01 BootBlock Note Edited: 0000138
2020-01-02 11:01 BootBlock Note Edited: 0000138
2020-01-02 11:02 BootBlock Note Revision Dropped: 138: 0000204
2020-01-02 11:02 BootBlock Note Revision Dropped: 138: 0000205
2020-01-02 11:03 BootBlock Note Edited: 0000138
2020-01-02 11:03 BootBlock Note Edited: 0000138 View Revisions
2020-01-02 11:03 BootBlock Note Revision Dropped: 138: 0000206
2020-01-02 11:03 BootBlock Note Revision Dropped: 138: 0000207
2020-01-02 11:04 BootBlock Status new => resolved
2020-01-02 11:04 BootBlock Resolution open => fixed
2020-01-21 16:24 BootBlock Status resolved => closed