View Issue Details

IDProjectCategoryView StatusLast Update
0000233Wake On LAN Ex[All Projects] Backend / Corepublic2018-11-10 16:55
ReporterAppFrameworkAssigned ToBootBlock 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.19 
Target Version3.20Fixed in Version3.20 
Summary0000233: Exception: Object reference not set to an instance of an object.
Description

This report has been created by the AppFramework framework on which the Wake On Lan EX application has been built.
This report has been submitted with the user's express permission.


APPLICATION INFORMATION

  • Version: 3.19
  • Uptime: 4 minutes(s), 12 seconds
  • Command Line: C:\Program Files\Wake On LAN Ex\Wake On Lan EX.exe
  • Open Forms
    • WakeOnLanEX.Forms.Main
      • TopMost: Yes
    • BiQubic.Controls.Forms.ColumnEditor
      • Visible: No
  • Loaded Assemblies
    • mscorlib, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Wake On Lan EX, Version=3.19.0.0
    • System.Windows.Forms, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Drawing, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • BiQubic.Suite.Core, Version=1.23.0.0
    • BiQubic.Suite.FileSystem, Version=1.15.0.0
    • BiQubic.Suite.Metro, Version=1.22.0.0
    • BiQubic.Suite.Controls, Version=1.10.0.0
    • Microsoft.VisualBasic, Version=10.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Core, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Web, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Management, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Configuration, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Xml, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Newtonsoft.Json, Version=11.0.0.0, PublicKeyToken=30ad4fe6b2a6aeed
    • System.Numerics, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Runtime.Serialization, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Data, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Plugin.Registered, Version=3.2.0.0
    • BiQubic.ColumnEditor, Version=1.2.0.0
    • BiQubic.Hardware.LGK, Version=1.1.0.0
    • System.Security, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • Accessibility, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • MantisSharp, Version=1.0.0.0, PublicKeyToken=05b8fbd1b10b2d7e

EXCEPTION

MESSAGE
  • Object reference not set to an instance of an object.
SOURCE
  • BiQubic.ColumnEditor
TARGET SITE
  • Name: PopulateColumns
  • MemberType: Method
  • Module: BiQubic.ColumnEditor.dll
STACKTRACE
  • at BiQubic.Controls.Forms.ColumnEditor.PopulateColumns()
  • at BiQubic.Controls.Forms.ColumnEditor.ColumnEditor_Load(Object sender, EventArgs e)
  • at System.Windows.Forms.Form.OnLoad(EventArgs e)
  • at System.Windows.Forms.Form.OnCreateControl()
  • at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
  • at System.Windows.Forms.Control.CreateControl()
  • at System.Windows.Forms.Control.WmShowWindow(Message& m)
  • at System.Windows.Forms.Control.WndProc(Message& m)
  • at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
  • at System.Windows.Forms.Form.WmShowWindow(Message& m)
  • at System.Windows.Forms.Form.WndProc(Message& m)
  • at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
  • at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
  • at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

APPFRAMEWORK INFORMATION

  • Version: 1.23
  • Systray: Yes
  • Theming: Yes
  • LaunchCount: 72
  • TotalDuration: 3.16:08:04.0179823

SYSTEM INFORMATION

  • ID: 0EA7ED40254BD7DE6DA91D4F7ADAEF73B86AE09A
  • Operating System: Microsoft Windows 10 Home (10.0.17134.0; Win32NT; x86)
  • Physical Memory: 626 MB free of 1,912 MB
  • Virtual Memory: 1,697 MB free of 2,047 MB
  • Working Set: 59 MB
  • CPUs: 4
  • Battery Status: Low at 0.22%
  • Screen Orientation: Angle270

ENVIRONMENT

  • Displays: 1280x800x32 (1280x770)*
  • .NET Frameworks: 2.0, 3.0, 3.5, 4 Client, 4 Full
  • .NET Version: 4.0.30319.42000
  • Culture: en-GB (English (United Kingdom))
  • Input Language: en-GB (United Kingdom)
  • VisualStyles: Enabled

USER COMMENTS

Joe,

I have noidea what has hapenned.

I have tried to remove ad re-install Home Edition and it isn't working.

I would appreciate you help to get your excellent and useful program back onto my system.

Thank you.

Best wishes,
A.

APPFRAMEWORK LOG

  • [10/11/2018 at 10:57:49] Startup Information Wake On Lan EX v3.19.0.0
  • [10/11/2018 at 10:57:50] Startup Information OS: Microsoft Windows 10 Home 10.0.17134.0 (Win32NT; x86). CPUs: 4.
  • [10/11/2018 at 10:57:50] Startup Information Memory: 393MB of 1.87GB free.
  • [10/11/2018 at 10:57:50] Startup Information UI Culture: English (United Kingdom)
  • [10/11/2018 at 10:57:50] Startup Debug Exception handler has been initialised to use MantisBT.
  • [10/11/2018 at 10:57:51] Plugins Debug Found plugins: Plugin.Registered.dll
  • [10/11/2018 at 10:57:52] System Warning Error initialising column editor: Object reference not set to an instance of an object.
  • [10/11/2018 at 11:02:05] AppFramework Fatal An exception has been caught: Object reference not set to an instance of an object.
Steps To Reproduce

While this may not be the steps required to reproduce the source of this particular error, it seemed to still reproduce the symptom.

  1. Edit the %APPDATA%\WoLEX3\Columns.jso file and corrupt it by adding/removing random characters.
  2. Run WoLEX and it should result in the above issue.
TagsException

Activities

BootBlock

2018-11-10 11:20

administrator   ~0000004

There seems to be an issue with the column editor; I've not encountered this error before, so a little bit of investigating will be required but at first glance, I can't think why something would be missing (eg. the column data itself, maybe?).

BootBlock

2018-11-10 11:33

administrator   ~0000005

Last edited: 2018-11-10 11:41

View 2 revisions

I've managed to replicate the issue in that it's giving the same errors, but I'm not entirely sure if that's the way that this error actually occurred.

As a workaround while fixing/releasing this problem, you could try deleting the Columns.jso that resides in %APPDATA%\WoLEX3. Then running WoLEX should hopefully work; it seems that the Columns.jso file got corrupted in some way and WoLEX is having a problem correctly interpreting its contents.

BootBlock

2018-11-10 11:43

administrator   ~0000006

The issue has now been fixed!

If WoLEX encounters corrupted column data, it'll now just reset that data back to the defaults. It was originally doing this, but it wasn't quite rigorous enough in its detection.

Wake On LAN Ex 3.20 should be released within the next few hours with this fix, and a couple of additional fixes to the error reporting as I've noticed some little formatting issues in this submission.

BootBlock

2018-11-10 12:09

administrator   ~0000007

Will mark this resolved once this has been confirmed to be fixed.

BootBlock

2018-11-10 16:55

administrator   ~0000008

Initial testing appears to show that the error is fixed on the client's machine.

There are a few other error-checking changes I'd like to make which'll cause the next release to be available in the following few days (as opposed to same-day as the fix), it'll give a bit of time should the fix not actually be a 100% solution to the problem and so I don't release a "faux-fixed" release. If that makes sense.

Issue History

Date Modified Username Field Change
2018-11-10 11:05 AppFramework New Issue
2018-11-10 11:05 AppFramework Assigned To => BootBlock
2018-11-10 11:13 BootBlock Description Updated View Revisions
2018-11-10 11:20 BootBlock Note Added: 0000004
2018-11-10 11:33 BootBlock Note Added: 0000005
2018-11-10 11:34 BootBlock Priority normal => high
2018-11-10 11:34 BootBlock Severity minor => crash
2018-11-10 11:34 BootBlock Reproducibility have not tried => always
2018-11-10 11:34 BootBlock Status new => confirmed
2018-11-10 11:34 BootBlock Product Version => 3.19
2018-11-10 11:34 BootBlock Fixed in Version => 3.20
2018-11-10 11:34 BootBlock Target Version => 3.20
2018-11-10 11:35 BootBlock Tag Attached: Exception
2018-11-10 11:41 BootBlock Note Edited: 0000005 View Revisions
2018-11-10 11:43 BootBlock Note Added: 0000006
2018-11-10 11:44 BootBlock Status confirmed => resolved
2018-11-10 11:44 BootBlock Resolution open => fixed
2018-11-10 12:03 BootBlock Description Updated View Revisions
2018-11-10 12:05 BootBlock Steps to Reproduce Updated View Revisions
2018-11-10 12:05 BootBlock Steps to Reproduce Updated View Revisions
2018-11-10 12:09 BootBlock Status resolved => confirmed
2018-11-10 12:09 BootBlock Resolution fixed => open
2018-11-10 12:09 BootBlock Note Added: 0000007
2018-11-10 16:55 BootBlock Note Added: 0000008
2018-11-10 16:55 BootBlock Status confirmed => resolved
2018-11-10 16:55 BootBlock Resolution open => fixed