View Issue Details

IDProjectCategoryView StatusLast Update
0000260Wake On LAN Ex[All Projects] Backend / Corepublic2018-12-18 09:21
ReporterAppFrameworkAssigned ToBootBlock 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
Product Version3.20 
Target Version3.21Fixed in Version3.21 
Summary0000260: Exception: Additional non-parsable characters are at the end of the string.
Description

This report has been created by the AppFramework framework on which the Wake On Lan EX application has been built.
This report has been submitted with the user's express permission.


APPLICATION INFORMATION

  • Version: 3.20
  • Uptime: 7 seconds
  • Command Line: C:\Program Files (x86)\Wake On LAN Ex\Wake On Lan EX.exe
  • Open Forms
    • WakeOnLanEX.Forms.Main
  • Loaded Assemblies
    • mscorlib, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Wake On Lan EX, Version=3.20.0.0
    • System.Windows.Forms, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • BiQubic.Suite.Core, Version=1.24.0.0
    • System.Drawing, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • BiQubic.Suite.FileSystem, Version=1.15.0.0
    • BiQubic.Suite.Metro, Version=1.22.0.0
    • System, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • BiQubic.Suite.Controls, Version=1.10.0.0
    • Microsoft.VisualBasic, Version=10.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Web, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Core, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Management, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Configuration, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Xml, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Newtonsoft.Json, Version=11.0.0.0, PublicKeyToken=30ad4fe6b2a6aeed
    • System.Numerics, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Runtime.Serialization, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Data, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Accessibility, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • BiQubic.ColumnEditor, Version=1.3.0.0
    • System.Security, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • BiQubic.MagicPacket, Version=1.3.0.0
    • MantisSharp, Version=1.0.0.0, PublicKeyToken=05b8fbd1b10b2d7e

EXCEPTION

MESSAGE
  • Additional non-parsable characters are at the end of the string.
SOURCE
  • mscorlib
TARGET SITE
  • Name: StringToInt
  • MemberType: Method
  • Module: mscorlib.dll
STACKTRACE
  • at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
  • at System.Convert.ToByte(String value, Int32 fromBase)
  • at BiQubic.MagicPacket.Device.set_MacId(String value)

ADDITIONAL INFORMATION

  • Common.Forms.Main.tbrMain\_Action\_Custom.DropDownItems.Count = [1] '2'

APPFRAMEWORK INFORMATION

  • Version: 1.24
  • Systray: Yes
  • Theming: Yes
  • HasStartupErrors: Yes
  • LaunchCount: 4
  • TotalDuration: 00:15:47.9817401

SYSTEM INFORMATION

  • ID: 393D3E5794392DEB790FA21BBE820453C94AF5F1
  • Operating System: Microsoft Windows 10 Pro (10.0.17134.0; Win32NT; x64)
  • Physical Memory: 1,182 MB free of 3,823 MB
  • Virtual Memory: 1,724 MB free of 2,047 MB
  • Working Set: 59 MB
  • CPUs: 4

ENVIRONMENT

  • Displays: 1280x1024x32 (1280x1024)*
  • .NET Frameworks: 2.0, 3.0, 3.5, 4 Client, 4 Full
  • .NET Version: 4.0.30319.42000
  • Culture: en-US (English (United States))
  • Input Language: en-GB (United Kingdom)
  • VisualStyles: Enabled

APPFRAMEWORK LOG

  • [17/12/2018 at 10:35:06] Startup Information Wake On Lan EX v3.20.0.0
  • [17/12/2018 at 10:35:06] Startup Information OS: Microsoft Windows 10 Pro 10.0.17134.0 (Win32NT; x64). CPUs: 4.
  • [17/12/2018 at 10:35:06] Startup Information Memory: 1.18GB of 3.73GB free.
  • [17/12/2018 at 10:35:06] Startup Information UI Culture: English (United States)
  • [17/12/2018 at 10:35:06] Startup Debug Exception handler has been initialised to use MantisBT.
  • [17/12/2018 at 10:35:06] Plugins Verbose Plugins directory exists but is empty. Plugin support is set to ScanInstantiate.
  • [17/12/2018 at 10:35:15] AppFramework Fatal An exception has been caught: Additional non-parsable characters are at the end of the string.
TagsNo tags attached.

Activities

BootBlock

2018-12-17 14:45

administrator   ~0000020

Thanks for the submission! Will investigate and update this task with additional information...

BootBlock

2018-12-17 16:40

administrator   ~0000021

While there seems to be an issue with errors not being caught correctly (which is now fixed), I can't seem to get this specific Additional non-parsable characters are at the end of the string error to occur.

If you're willing to, could you please create an account and add a note to this task report specifying what the actual entered MacID was? I'll keep trying to replicate it...

BootBlock

2018-12-18 09:20

administrator   ~0000022

While I still can't replicate this, I've fixed the issues I ran into while testing.

I'm going to leave this task open for now just in case the original submitter adds a comment detailing the MacID that was used to cause this, but for now, it's tentatively "fixed".

Issue History

Date Modified Username Field Change
2018-12-17 10:37 AppFramework New Issue
2018-12-17 10:37 AppFramework Assigned To => BootBlock
2018-12-17 14:45 BootBlock Note Added: 0000020
2018-12-17 16:40 BootBlock Note Added: 0000021
2018-12-18 09:20 BootBlock Note Added: 0000022
2018-12-18 09:21 BootBlock Reproducibility have not tried => unable to reproduce
2018-12-18 09:21 BootBlock Status new => resolved
2018-12-18 09:21 BootBlock Resolution open => unable to reproduce
2018-12-18 09:21 BootBlock Product Version => 3.20
2018-12-18 09:21 BootBlock Fixed in Version => 3.21
2018-12-18 09:21 BootBlock Target Version => 3.21