View Issue Details

IDProjectCategoryView StatusLast Update
0000301Comica 2[All Projects] Backend / Corepublic2019-02-05 14:43
ReporterBootBlockAssigned ToBootBlock 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.00 
Target Version2.00Fixed in Version 
Summary0000301: Duplicate comic image being downloaded
Description

When downloading a comic image strip that already exists, it is downloaded (as opposed to the cached copy being returned) to disk without its file extension. Presumably, this is because Comica hasn't set its extension at that point and so is being downloaded as a new file.

TagsNo tags attached.

Relationships

related to 0000283 newBootBlock Add events to Definition 

Activities

BootBlock

2019-02-04 08:10

administrator   ~0000044

Added a new file checking function that determines if a file exists based on looping through a few common image extensions.

Not a fan of this extra I/O, but I can't remember how this works in Comica 1.xx. BiQubic.Comics should probably expose an event during the file existence check that Comica can interrogate and return its findings. Not sure.

For now, this has been fixed but will be re-investigated later.

Issue History

Date Modified Username Field Change
2019-02-02 18:52 BootBlock New Issue
2019-02-02 18:52 BootBlock Assigned To => BootBlock
2019-02-04 08:10 BootBlock Note Added: 0000044
2019-02-04 08:11 BootBlock Status new => resolved
2019-02-04 08:11 BootBlock Resolution open => fixed
2019-02-05 14:43 BootBlock Relationship added related to 0000283