View Issue Details

IDProjectCategoryView StatusLast Update
0000516FileSieveBackend / Corepublic2020-03-13 06:19
ReporterAppFramework Assigned ToBootBlock  
PriorityhighSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
OSWindows 10OS Version6.2.9200.0 
Product Version4.52 
Target Version4.53 
Summary0000516: `Exception`: Object reference not set to an instance of an object.
Description

This report has been created by the AppFramework framework on which the FileSieve application has been built.
This report has been submitted with the user's express permission.


APPLICATION INFORMATION

  • Version: 4.52
  • Uptime: 31 seconds
  • Command Line: C:\Program Files (x86)\FileSieve\FileSieve4.exe
  • Open Forms
    • FS.Main.Forms.Main
  • Loaded Assemblies
    • mscorlib, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • FileSieve4, Version=4.52.0.0
    • System.Windows.Forms, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Drawing, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • BiQubic.Framework, Version=2.0.0.0
    • FileSieve4.Plugins, Version=4.51.0.0
    • Microsoft.VisualBasic, Version=10.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Core, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Web, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Xml, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Configuration, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • Accessibility, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • System.Management, Version=4.0.0.0, PublicKeyToken=b03f5f7f11d50a3a
    • Newtonsoft.Json, Version=12.0.0.0, PublicKeyToken=30ad4fe6b2a6aeed
    • System.Numerics, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Runtime.Serialization, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • System.Data, Version=4.0.0.0, PublicKeyToken=b77a5c561934e089
    • Method.Attributes, Version=1.7.0.0
    • Method.Classification, Version=1.9.0.0
    • Method.Consolidate, Version=1.5.0.0
    • Method.DateStamp, Version=1.8.0.0
    • Method.Delimiter, Version=1.0.0.0
    • Method.Exif, Version=1.9.0.0
    • Method.Extension, Version=1.5.0.0
    • Method.FindReplace, Version=1.8.0.0
    • Method.Mirror, Version=1.5.0.0
    • Method.ParentRename, Version=1.1.0.0
    • Method.Quantity, Version=1.6.0.0
    • Method.StandardAtoZ, Version=1.7.0.0
    • Method.Substring, Version=1.4.0.0
    • Method.Tag, Version=1.14.0.0
    • Modifier.Attributes, Version=1.7.0.0
    • Modifier.Casing, Version=1.6.0.0
    • Modifier.DateStamp, Version=1.2.0.0
    • Modifier.FindReplace, Version=1.8.0.0
    • ExifLib, Version=1.7.0.0
    • MantisSharp, Version=1.0.0.0, PublicKeyToken=05b8fbd1b10b2d7e

EXCEPTION

MESSAGE
  • Object reference not set to an instance of an object.
SOURCE
  • FileSieve4
TARGET SITE
  • Name: ProcessSourceItem_DeleteEmptySubFolders
  • MemberType: Method
  • Module: FileSieve4.exe
STACKTRACE
  • at FS.Main.Core.Process.ProcessSourceItem_DeleteEmptySubFolders()
  • at FS.Main.Core.Process.Process_ProcessSourceItems()
  • at FS.Main.Core.Process.DoStart(Object value)
  • at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
  • at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
  • at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
  • at System.Threading.ThreadHelper.ThreadStart(Object obj)

ADDITIONAL INFORMATION

  • Profile.Name = [15] 'Default Profile'
  • Profile.ActiveModifiers.Count = [1] '0'

APPFRAMEWORK INFORMATION

  • Version: 2
  • Languages: Yes
  • LaunchCount: 4
  • TotalDuration: 00:00:00

SYSTEM INFORMATION

  • ID: 8BB767C92007F90C27F6C9E9D8851971E4D08B51
  • Operating System: Microsoft Windows 10 Home (6.2.9200.0; Win32NT; x64)
  • Physical Memory: 4,806 MB free of 8,076 MB
  • Virtual Memory: 134,212,815 MB free of 134,217,727 MB
  • Working Set: 93 MB
  • CPUs: 4

ENVIRONMENT

  • Displays: 1280x720x32 (1280x680)*, 1280x720x32 (1280x680)
  • .NET Frameworks: 2.0, 3.0, 3.5, 4 Client, 4 Full
  • .NET Version: 4.0.30319.42000
  • Culture: en-US (English (United States))
  • Input Language: en-CA (US)
  • VisualStyles: Enabled

APPFRAMEWORK LOG

  • User chose not to include log.
    withheld: 59 entries
TagsNo tags attached.

Activities

BootBlock

2020-03-11 20:14

administrator   ~0000241

Hi there,

thanks for submitting the report - I'm currently looking into the issue and will report back. But, at first glance, it appears I'm going to have to do some in-depth testing as it isn't obvious why this is happening.

BootBlock

2020-03-11 21:02

administrator   ~0000242

I can't seem to reproduce this at all; if possible, could you please create an account and give more information such as Active Method, any modified Source Item options, etc? In the meantime, I'll keep trying to reproduce the problem as I'd rather find the actual cause rather than just mask the symptom.

BootBlock

2020-03-11 22:13

administrator   ~0000243

Last edited: 2020-03-11 22:14

View 1 revisions

I've put in a temp fix until I can reproduce the exception. As an aside, a lot more relevant (non-identifying) information is reported when an exception is submitted as the Additional Data section above doesn't say anything useful.

Issue History

Date Modified Username Field Change
2020-03-11 17:36 AppFramework New Issue
2020-03-11 17:36 AppFramework Assigned To => BootBlock
2020-03-11 20:14 BootBlock Note Added: 0000241
2020-03-11 21:02 BootBlock Priority normal => high
2020-03-11 21:02 BootBlock Severity minor => major
2020-03-11 21:02 BootBlock Reproducibility have not tried => unable to reproduce
2020-03-11 21:02 BootBlock Status new => acknowledged
2020-03-11 21:02 BootBlock OS => Windows 10
2020-03-11 21:02 BootBlock OS Version => 6.2.9200.0
2020-03-11 21:02 BootBlock Product Version => 4.52
2020-03-11 21:02 BootBlock Target Version => 4.53
2020-03-11 21:02 BootBlock Note Added: 0000242
2020-03-11 22:13 BootBlock Note Added: 0000243
2020-03-11 22:14 BootBlock Note Edited: 0000243 View Revisions
2020-03-11 22:14 BootBlock Note Revision Dropped: 243: 0000280
2020-03-13 06:19 BootBlock Status acknowledged => resolved
2020-03-13 06:19 BootBlock Resolution open => unable to reproduce