View Issue Details

IDProjectCategoryView StatusLast Update
0000022FileSieveBackend / Corepublic2020-04-19 15:59
ReporterBootBlock Assigned ToBootBlock  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Target Version4.55Fixed in Version4.55 
Summary0000022: No processed items prevents BeginInvoke from working
Description

Example: Classification Method not finding any matches if no items are processed.

The problem appears to be related to there being items to be processed, but they have all been set to Item.IsProcessed = False. This means that no items have been processed, which seems to cause a problem with the Windows Taskbar progress indicator.

Fixing this will have to be an ongoing process; in the meantime, EnableTaskbarProgress has been added to Settings - Advanced and should be set to False should the issue of the FileSieve window staying disabled after processing has completed.

TagsProcessing

Activities

BootBlock

2020-04-17 23:42

administrator   ~0000261

Not sure if this is the same sorta thing, but changing Forms.Main.BeginInvoke(cb) to Forms.Main.Invoke(cb) fixed the sieving never completing when using the Classification (and maybe others?) method if no results are returned.

BootBlock

2020-04-19 15:58

administrator   ~0000262

Turns out Invoke and BeginInvoke never even attempt to launch their code when called from the processing through. A temporary workaround is to then launch another thread from the Processing thread to do UI stuff. Annoying, but at least the insanely-fast (20,000 files/sec vs 200 files/sec for Yield) Burst Get Files Mode can now be made the default.

BootBlock

2020-04-19 15:59

administrator   ~0000263

Quick addition: It didn't seem to matter (this time?) whether any files were processed or not; it just seemed random if the invokes would work.

Issue History

Date Modified Username Field Change
2018-10-05 23:04 BootBlock New Issue
2018-10-05 23:04 BootBlock Status new => assigned
2018-10-05 23:04 BootBlock Assigned To => BootBlock
2018-10-05 23:04 BootBlock Tag Attached: Processing
2020-04-17 23:42 BootBlock Note Added: 0000261
2020-04-19 15:58 BootBlock Note Added: 0000262
2020-04-19 15:58 BootBlock Status assigned => resolved
2020-04-19 15:58 BootBlock Resolution open => fixed
2020-04-19 15:58 BootBlock Fixed in Version => 4.55
2020-04-19 15:58 BootBlock Target Version => 4.55
2020-04-19 15:59 BootBlock Note Added: 0000263